Our products compatibility with Joomla! 3.4.3

We have just updated our Perfect Everything in Everyway extension to version 2.0.4, thus making it fully compatible with the newest Joomla! version 3.4.3. Make sure to update your extension and remember to put your Download ID found in My subscriptions section on our website to Advanced > Download ID field in our module configuration, to be able to do so! Current versions of the rest of our extensions are compatible with Joomla! 3.4.3. We will keep you posted as to any more development updates.